More reasons why browsers and flash suck

Post by: on January 30, 2008 | 0 Comment

Mac Firefox ( has a few bugs. One of them is this weird font anti-aliasing bug where fonts are anti-aliased at one setting in a normal page, but if you set the opacity of any object on that page, then they swap into a different mode. You can see the font strokes getting thicker or thinner. It’s really obvious with bold fonts. We ran into this issue with a recent release. On our home page were two rotating banners, we use Scriptaculous to Fade() and Appear() each one, so they cross fade into each other. Saves real-estate nicely. However, when it started the cross fade, the fonts would thin, then when it was done, they would thicken back up. It didn’t bother me, but the higher ups thought it was a catastrophe, so I hunted around for a solution. Eventually we hit on setting “-moz-opacity: 99” on the body element, forcing it into one mode all the time. So we cruise along with that for 6 months until we add some flash to another page in the site. Works great for everyone but poor little old me in FF Mac. If the flash has “wmode” set to “transparent” the flash object appears, but then goes blank, and only appears in parts where my mouse drags over it. In that setting our DHTML menus don’t appear in front of it, so it’s useless.So we switch to “wmode=opaque” and it “solves” that problem, now the flash box is completely empty all the time. Some googling around points me to problems between flash and CSS opacity, so my first thought was to take out that -moz-opacity declaration and whaddayaknow, everything works. So we override that opacity setting on the flash page and we’re all good.